Simple YouTube Embed Plugin


Simple YouTube Embed is a WordPress plugin which makes your YouTube videos responsive and prettier.

Simple YouTube Embed Plugin Installation

  • Login to your WordPress admin dashboard
  • Go to Plugins->Add New
  • Enter Simple YouTube Embed in the search box
  • Once you find the plugin hit the install button

Option 2

  • Download the zip version of the plugin
  • Go to Plugins->Add New and switch to the Upload tab
  • Select the zip file on your computer
  • Upload and install it

Option 3

  • Download the zip file and extract it
  • Connect to your website via FTP (you can use a software like Filezilla to transfer files to your server) and browse to the “/wp-content/plugins” folder
  • Select the folder containing the plugin files on your computer and upload it
  • Once all the files have been uploaded to your web server you can activate the plugin from the Plugins menu (WordPress admin dashboard)

Simple YouTube Embed Plugin Usage

You can easily embed a YouTube video by inserting the URL into your visual/text editor. For example:

screenshot showing how to embed a youtube url in wordpress

Once you publish the post/page your YouTube video should like the following:

screenshot of a YouTube video using the simple youtube embed plugin

If you already have some YouTube videos embedded the plugin will automatically make them pretty like the one above.

Disable Related Videos

Adding “rel=0” to the URL will disable related videos from displaying when the YouTube video finishes.

http://www.youtube.com/watch?v=Vpg9yizPP_g&rel=0

Disable Player Controls

Adding “controls=0” to the URL will disable YouTube player controls.

http://www.youtube.com/watch?v=Vpg9yizPP_g&controls=0
If you really like the plugin please give it a rating here (I will really appreciate it)
Users who like Simple YouTube Embed also like WP eStore plugin to sell videos in WordPress.

51 thoughts on “Simple YouTube Embed Plugin

      • @wpguide. No the video doesn’t render even when I deactivate your plugin.
        Strange isn’t it?
        What to do?

      • @Marek, The embed feature comes from WordPress. So it should at least work with the plugin deactivated.

        Please switch to the text editor to make sure that there is no hidden character or HTML tag in it.

      • @wpguide. I checked in Text mode and there are no hidden characters or HTML tags there, still does not work at all even with the other types of URLs like below.
        Any other ideas?
        Thanks!

      • @Marek, I believe the oEmbed option is not working on your server. Have you contacted your hosting provider yet? They should be able to look into this issue.

      • @wpguide. Yes, I contacted the hosting admin and the ‘mystery’ is solved. They said:
        “Due to the high amount of abuse and increased security needs we have disabled by default all outgoing connections for free user accounts.
        Allowed outgoing connections are only available for paid accounts, you need to upgrade to a paid account in order to use it.”
        Well, at least I know now…
        Thanks again for all your help!

  1. Hi,
    I’m trying to get it working but so far no success. The page is here:
    http://memoryisourhome.byethost31.com/authors-note/
    and the URL at the bottom of the page is:
    https://www.youtube.com/watch?v=c3EnbQvpgZM&rel=0

    Maybe I’m doing something wrong… I’m very new in this.
    Any ideas why it does not work?

    Thanks.

  2. Question…when I add the “rel=0” to the end of the code to disable the related videos from displaying at the end, all I see is a black screen with the YouTube play arrow. Without the addition of the “rel=0” at the end, the first image from my video appears. Is there someway to disable the related videos and yet still show the first image from my video?

    Thank you!

  3. Thank you for a very helpful plugin.

    Quick question – the YouTube video is responsive in the admin panel for the page it’s on, but not on the actual site.

    Did I miss something?

    Thanks for your time.

  4. Hi, thanks for the plugin.

    Could you update to the most recent version of PrettyEmbed.js in the next release of your plugin since it provides way more options.

    Cheers

  5. I love the appearance of this player on my new website. Thank you for creating it! My question is about Vimeo videos. Is there a way to replay(loop) the video instead of going to the default Vimeo end-of-video screen where multiple other videos are displayed? Same question about YouTube. Thanks! Dia

  6. I’m also getting a blank grey screen (no thumbnail) with low res video. Additionally, at the end of the video, it loads a random video in.

  7. This plugin works in Chrome, Andoid browser, IPAD browsers, and Internet Explorer 9.

    However, the video does not show in Internet Explorer 10 and Internet Explorer 11.

    The div tag is in the page code, however, it does not show in the browser.

    Any ideas on how to get this work in IE 10 or 11?

  8. Oh, I got it.
    The poster frame only shows if the video has an HD version, is that right?

    If that’s the case, that’s something really bad for editors and authors because there’s a lot of videos w/o HD. Is there any way to avoid the ugly blank grey screen?

    I hope so because the plugin is great and works really well with the HD videos.

    Tks a lot!

  9. Hi!
    Nice plugin!

    On my site it works on some posts and some not.

    Here it works nicely:

    http://www.updateordie.com/2014/08/31/mulher-como-mero-objeto-video-disseca-o-sexismo-dos-videogames/

    But not here:

    http://www.updateordie.com/2014/08/28/dj-cria-faixa-partir-de-1-000-sons-produzidos-por-maquinas-da-ge/

    Any clues?

    Thanks a lot!

      • Hi!
        A HD version? I don’t know, they are all embeds from yt, our authors usually just drop the url w/o any further settings…
        The theme is new and I’m still regenerating thumbnails… Could it be related?

        Tks!

  10. Curious like Don is on how to resize the embedded video, as well.

    Great plugin! Worked the first time with my current configuration.

      • @talorb, are you using a caching plugin? All the JavaScript files are getting included in the wrong way. It’s also causing some errors on that page.

      • @wpguide Thanks. I went through and disabled any plugins I thought would be causing issue and it still didn’t work. I guess I’ll just go without.

      • @talorb, have you disabled “quick cache” or any minify options that you are using? Once the scripts are loaded correctly I might be able to track the issue.

      • Yes, both plugins are currently disabled and it still does not work. I’ll leave them disabled if you’d like to troubleshoot. Thanks again.

      • @talorb, actually I just noticed something. How did you insert the video URL? You need to embed it like the following for the plugin to work:

        http://www.youtube.com/watch?v=LDpX9CPIpiY

      • It is embedded just like that. I don’t know what could be causing the issue. I even tried creating a simple post with just the video URL and it produces the same result.

        Thanks for your help anyhow.

      • @talorb, that’s a little strange. The final embed code is not even coming from the plugin. Do you have any plugin that filters YouTube code or does something with it (It could even be the theme)?

      • I got it working. Just so you know for future reference or documentation, it was a setting in the popular Jetpack plugin. I had to disable the “Shortcode Embeds” option within it to get the plugin to work.

        Funny though, that disabling the Jetpack plugin itself didn’t allow it to work.

  11. how do I set the videos to not automatically start playing? Don’t need 5 videos playing at the same time, half of them twice.
    Thanks!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s